After upgrading CA Process Automation Manager from 4.3 SP5 to 4.4, users cannot login
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After upgrading CA Process Automation Manager from 4.3 SP5 to 4.4, users cannot login

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Article ID: 270848

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After upgrading CA Process Automation Manager from 4.3 SP5 to 4.4, users cannot login

 

Environment

Release : 4.4

Cause

When we start PAM, it will spin up two java.exes. One for PAM and another one for ActiveMQ

As the targethost contains two IP addresses (TWO NICs), somehow WildFly (It's application server used by PAM) is binding to 2nd IP which is causing the issue.

Resolution

We applied the following fix to enforce the WildFly to pick the right IP Address.

  • Modified the etc/host file by adding the ip,hostname and FQDN details.
  • Modified the PAM OasisConfig.properties file with the right IP Address.
  • Modified the PAM c2osvcw.conf file with the right IP Address.