Server IP could not be found for CASB OIDC Broker for SpanVA SSO
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Server IP could not be found for CASB OIDC Broker for SpanVA SSO

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Article ID: 270770

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Updated On:

Products

CASB Audit CASB Security Advanced CASB Security Premium CASB Security Standard

Issue/Introduction

This latest CloudSOC release enables SpanVA versions 1.15.3.150.0-18rc and above to use SSO with Broadcom Login to authenticate with CloudSOC. However, the customer received error "xxxx.com server IP could not be found" and never received the admin email when trying to configure SSO. 

Environment

SpanVA 1.15.3.150.0-18rc

CloudSOC Release 3.160

Cause

SpanVA had incorrect FQDN set which lead to incorrect redirect URLs in oidc_client_info object.

Resolution

Engineering modified it manually on SpanVA to make OIDC login work. But as soon as it synced with CloudSOC it received incorrect values again. 

Engineering updated the database collection with correct values and fixed the issue for the customer directly. 

Permanent fix for all customers will be included in the next CloudSOC Release 3.161.