Inventory Solution license count exceeds the expected in-use licenses totals
search cancel

Inventory Solution license count exceeds the expected in-use licenses totals

book

Article ID: 270634

calendar_today

Updated On:

Products

Inventory Solution

Issue/Introduction

Symantec Installation Manager shows certain number of used licenses. However, according to administrator number of machines involved in inventory is much less.

Environment

ITMS 8.6, 8.7

Cause

Resource removal via API properly reclaims license.
Resource removal by other methods may leave number of leftovers in the database, causing this issue.

Resolution

Review the following KB article in order to validate that you are looking at the right places for in-use licenses totals:

Viewing License Usage From the SMP Console

In this type of scenario, it will require cleaning up "ResourceUpdateSummary" table. This should resolve the problem.

  1. Run the following SQL query on the Symantec_CMDB database:

    DELETE FROM ResourceUpdateSummary WHERE ResourceGuid NOT IN (SELECT GUID FROM vResource)
    AND InventoryClassGuid IN
    (
        SELECT dc.Guid
        FROM DataClass dc
        INNER JOIN vItem vi on vi.Guid = dc.Guid
        WHERE vi.ProductGuid = 'cd39b720-f871-11d2-8643-00104b74a9df' --Inventory Solution
    );

  2. Restart "Altiris Services" service to recalculate licenses in use.