Software view vs Asset report are showing discrepancies on returned results
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Software view vs Asset report are showing discrepancies on returned results

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Article ID: 270581

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Updated On:

Products

Client Management Suite

Issue/Introduction

You have configured a software product (Visio Professional); in the software view you see 111 installations, but from the Asset and Service Management - Software License view, you see 115 installations.
Another software product is Adobe Acrobat Professional, in the Software view you see 10 and the Asset and Service Management - Software License view, you see 0 installations.

Environment

ITMS 8.6

Cause

A week ago the compatibility was changed on the Symantec_CMDB database to SQL 2019 (150). The Software Product License Recalculation Operation Task indicates that it was completed, but they saw that in the "Asset and Service Management - Software License" view the data had not been updated.

Resolution

The error was caused by a stored procedure that is not optimized for newer SQL compatibility levels. Our development team re-wrote the stored procedure to optimize it to better work with the newer SQL server compatibility levels and any changes that Microsoft made. This new stored procedure, along with other improvements has been added to ITMS 8.6 RU3 and later.