Spectrum Landscape down in OneClick with error - "SPC-OCA-10364: No permission"
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Spectrum Landscape down in OneClick with error - "SPC-OCA-10364: No permission"

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Article ID: 270456

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Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

Landscape shows down in both OneClick client console and WEB GUI -> Administration -> Landscapes page with error:

SPC-OCA-10364: No permission. Ensure the server's .hostrc permits the web server host to connect.

Environment

DX NetOps Spectrum all currently supported releases

Cause

Possibly caused by lockout of accounts in LDAP

Resolution

Looking in the OneClick server log ($SPECROOT/tomcat/logs/catalina.out) the following error is repeatedly generated:

26- Jul-2023 01:15:05.641 WARNING [https-host-8443-exec-18]
             
com.aprisma.tomcat.authenticator.SpectrumLockOutRealm. filterLockedAccounts SpectrumLockOutRealm.authLockedUser

So, the user account is locked, OneClick saying user has no permission to access the landscape.

To fix this, you can edit  the context.xml file under:

$SPECROOT/tomcat/webapps/spectrum/META-INF

Change the value of LockOutTime from 600 to 0 (to eliminate user lockout after 5 password attempt failures):

<Realm className-"com. aprisma. tomcat, authenticator. SpectrumLockOutRealm" failureCount="5" LockOutTime="0">

Then restart Spectrum OneClick (Tomcat).