Siteminder smtrace log file is not rolling after defined size is reached
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Siteminder smtrace log file is not rolling after defined size is reached

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Article ID: 270374

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Updated On:

Products

SITEMINDER

Issue/Introduction

Siteminder policy server trace log file is not rolling over after reaching to 100MB size.

Below are the configuration for Profiler with 'Retain up to 10' old Trace Log file(s).

Environment

PolicyServer : 12.8.4

OS : Windows

Cause

The number of smtrace files to retain in the logs is set to 10, in this case.

Eleventh file will be created by deleting the oldest smtracefile, hence maintaining the number of trace file limit to 10 as set in the profiler.

Somehow, the oldest file is not getting deleted. Hence, not allowing to rollover to a new file and smtracedefault kept growing.

Resolution

Identify the process holding the oldest file using the 'Windows Task Manager > Processes'

Kill the process to delete the Old file from Windows.

Logs will start rolling over as intended.