Exporting Report in JasperReports 7.9 results in Phantomjs process did not end properly Error
search cancel

Exporting Report in JasperReports 7.9 results in Phantomjs process did not end properly Error

book

Article ID: 270158

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

When exporting a report with graphics pro in Jasper Server 7.9, the file is generated but where the graphics should be, the report has "Fusion Component Not Supported"

Error Message

net.sf.jasperreports.engine.JRRuntimeException: Phantomjs process did not end properly; exit value: 1; phantomjs output: <PhantomjsOut> fusionDataSourceStringVarName: fusionXMLString injecting script: jasperreports_fusion_1199822622_jquery-3.4.1.min.js injecting script: jasperreports_fusion_492753489_fusioncharts.js injecting script: jasperreports_fusion_2125415402_fusioncharts.charts.js injecting scriptfile: jasperreports_fusion_1689618141090_1148622571.js </PhantomjsOut>

Error Trace

com.jaspersoft.jasperserver.remote.exception.ExportExecutionRejectedException: net.sf.jasperreports.engine.JRRuntimeException: Phantomjs process did not end properly; exit

Environment

CA Service Desk Manager 17.3 

JasperReports 7.9

Cause

Chrome needs to be updated

Resolution

Jaspersoft requires Google Chrome web browser to be installed on the JasperReports server

Make sure that Google Chrome is updated to the latest release/version.