Harvest v14.5 database schema upgrade fails
search cancel

Harvest v14.5 database schema upgrade fails

book

Article ID: 269994

calendar_today

Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

We are upgrading Harvest SCM from 13.0.4 to 14.5 on a Redhat Linux server

Before upgrade, SCM's version.txt shows v13.0.4

>> cat /opt/CA/scm/version.txt
CA Harvest Software Change Manager v13 Build254
Built 2019/06/12 03:35:19 EDT

And database schema version shows 130300

SQL> select * from hartableinfo;

VERSIONINDICATOR C DATABASEID A S VERTRACKU
---------------- - ---------- - - ---------
  130300 Y    0 Y N 21-APR-21

HDBSetup UR option returns this message:

Database does not need to be updated

Environment

Release : 14.5.0

Cause

While using the hdbsetup utility to upgrade an existing database schema, it will request the Oracle "system" user account credentials and the Oracle "schema owner" user account credentials.  With previous Harvest versions, the Oracle "schema owner" user account credentials could be used as both the "system" credentials and the "schema owner" credentials, and the upgrade would succeed.  With this new version of Harvest, this "shortcut" will no longer work.  The database schema upgrade will not succeed without the Oracle "system" user account credentials and the Oracle "schema owner" user account credentials.

The upgrade documentation states that the only supported method for upgrading the Harvest database schema is to use the Oracle "system" user account credentials, and not to substitute another account when this one is requested.

The hdbsetup Database Configuration Utility

 

Resolution

Re-running HDBSetup and providing the Oracle "system" account credentials when requested resolved the problem and the database schema updated successfully.

Additional Information

The company policy and best practice in most organizations is to keep user account passwords secret and not to share them under any circumstances.  This means that the Oracle DBA must be available during the database upgrade process so that they can type in the password to the Oracle "system" account when required.  If this is not possible and an efix is needed, please contact support.