KB Attachments not Downloading in AWS
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KB Attachments not Downloading in AWS

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Article ID: 269739

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

After configuring an AWS load balancer in front of SDM, KB attachments are not working. 

When trying to download attachments to KBs, Browser Console mode shows the following:

jquery-3.6.0.min.js:2     Failed to load resource: the server responded with a status of 404 ()
send @ jquery-3.6.0.min.js:2

/CAisd/pdmweb.exe?SID=1809329541+FID=3755+OP=LINK_WITH_BOPSID+KEEP_ROLE=1+URL=javascript:parent.ahdframeset.downloadWin.Download(13176936,%27https://MYSERVER.COM/CAisd/UploadServlet%27,%27SERVERNAME%27,%25bopsid):1     Failed to load resource: the server responded with a status of 403 ()

jsrvr.log may display:

07/13 10:10:54.280 [TCP_port-Read:web:wsp] ERROR TCP_port 892 ReadInt Socketexception (did slump die?)java.net.SocketException: Connection reset 
07/13 10:10:55.291 [TCP_port-Read:web:local] ERROR TCP_port 892 ReadInt Socketexception (did slump die?)java.net.SocketException: Connection reset 
07/13 10:10:59.806 [TCP_port-Read:rep_daemon:MYSERVER] ERROR TCP_port 903 ReadInt EOFException (did slump die?)java.io.EOFException 
07/13 10:10:59.806 [TCP_port-Read:rep_daemon:MYSERVER] ERROR TCP_port 1322 Call to read_msg failed.java.net.SocketException 

Environment

Release : 17.3

Cause

Customers AWS WAF (Web Application Firewall) was blocking the download attempts

Resolution

Suggest involving customers AWS and Firewall teams to ensure the necessary exceptions are configured in the firewall