APMIA JMX Connection Failed to Server
search cancel

APMIA JMX Connection Failed to Server

book

Article ID: 269726

calendar_today

Updated On:

Products

DX Application Performance Management

Issue/Introduction

Installed the APM Infrastructure Agent, APMIA, with the extension for JMX remote monitoring.

The configuration is as follows (in this example the remote server is named prodjmx1 and listens on port 5004:

In bundle.properties for the jmx extension: 

introscope.agent.remotejmx.system.s1.name=<system_name>
introscope.agent.remotejmx.system.s1.hostport=<hostname>:5004

 

In the JVM parameters of the application:

-Dcom.sun.management.jmxremote.port=5004
-Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.ssl=false
However, it was not showing the expected metrics.
 
In logs, this error appeared:
 
[ERROR] [IntroscopeAgent.JMXClient] JMX Connection Failed to Server <hostname>:5004

The server is accessible from the host where the agent is installed and telnet server at the port works correctly.

Environment

Release: Any

Cause

Enabled DEBUG for the APMIA and got the following in logs:

 [DEBUG] [IntroscopeAgent.JMXClient] java.rmi.ConnectException: Connection refused to host: localhost; nested exception is: 
    java.net.ConnectException: Connection refused

For some reason, it is trying to connect to localhost instead of the configured hostname. 

Resolution

Added the following to the JVM arguments:

-Dcom.sun.management.jmxremote
-Djava.rmi.server.hostname=<IP_ADDRESS of the Server>