Discover Scan - Pause schedule is not working as expected
search cancel

Discover Scan - Pause schedule is not working as expected

book

Article ID: 269702

calendar_today

Updated On:

Products

Data Loss Prevention Network Discover Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

When the pause schedule is configured as below.

What is the customer expecting:

The scan should pause from Monday to Friday at 8 PM and resume the next day at 7 AM, The scan should also resume on Saturday at 7 AM and run until Monday till 8 PM.

What is actually happening:

The scan is getting paused correctly from Monday to Friday at 8 PM and resuming the next day at 7 AM.  However, the scan is not resuming on Saturday at 7 AM and is resuming directly on Monday at 7 AM.

Environment

Release: 15.x, 16.x

Cause

The pause-resume window mentioned in the schedule is crossing the day boundary. The schedule says to pause at 8 PM (Current Day) and resume at 7 AM (NextDay), On Friday - It paused the scan at 8 PM, and the day crossed, And since Saturday isn't selected on schedule, the resume did not trigger, neither so on Sunday. It directly resumed on Monday since its selected. The pause-resume window is defined in reversed here (PM to AM) in the context of the day (24hrs), causing the day to change in between the window.

Resolution

The schedule is working as per design based on the selection criteria. However, this use case is not covered.

We have created a feature request ISFR-2764 to evaluate this for future DLP releases.

Additional Information

Meanwhile there exist a workaround but from 16.0 onwards. Once the scan is paused on Friday at 8 PM, they can make use of rest-API to start/resume the scan on Saturday at any time they want. They can make use of the CURL command or any script for that matter and schedule like system Cron jobs or Task-Scheduler for that matter and keep it running. on Monday again schedule will kick in.