A2A client 402 null null errors due to slow PAM server response
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A2A client 402 null null errors due to slow PAM server response

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Article ID: 269684

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

We have multiple A2A clients for which requests tend to fail with a 402 error, because the PAM server takes more than the 30 seconds that the client application waits before it times out, before it returns a response to request. This happens for mappings that are defined for a request group, not the individual request servers. When we add a mapping for a given server specifically, the call completes fast.

Environment

Release : Affects any PAM release up to 4.1.4.

Cause

A task to get permissions for a request group could make thousands of database calls, if the group had a long history of changes, such as addition of new A2A clients to the group.

Resolution

The problem will be fixed in PAM 4.1.5+ and 4.2+. If you need a fix at a lower release, please open a case with PAM Support.