XCOMN1301E SCHEDULE REQUEST FAILED: UNABLE TO QUEUE TRANSFER
search cancel

XCOMN1301E SCHEDULE REQUEST FAILED: UNABLE TO QUEUE TRANSFER

book

Article ID: 269637

calendar_today

Updated On:

Products

XCOM Data Transport - Windows

Issue/Introduction

We are using new credentials(domain & userid) for the onward script. The transfers using the new credentials fails with message "XCOMN1301E SCHEDULE REQUEST FAILED: UNABLE TO QUEUE TRANSFER". The same transfer is successful when using the existing credentials.
 

 

Environment

Release : 12.0 and 11.6

XCOM Gateway for Windows

XCOM for Windows Server

Cause

After reviewing the traces provided we found message: 

UpdateQData: Unable to open C:\Program Files\CA\XCOM\q\0000nn.MBR write; OK for read; errno: 13 (Permission denied)

The message indicates that the credentials being used for the transfer don't have the proper permissions for the Queue directory.

 

Resolution

Issue the following command to verify the permissions on the Queue directory":  icacls "%xcom_home%\q"

In the output you should see "Everyone:(OI)(CI)(F)" indicating all users can read/write files. If that is not the case, you can then run the following command to add the missing permissions to the Queue directory:

icacls "%XCOM_HOME%\\q" /t /grant Everyone:F
icacls "%XCOM_HOME%\\q" /grant Everyone:(OI)(CI)F 

The result of the above commands should indicate that the command ran successfully: Successfully processed x files; Failed processing 0 files