Loop detected messages being flagged by the DLP Cloud Service for Email.
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Loop detected messages being flagged by the DLP Cloud Service for Email.

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Article ID: 269609

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Updated On:

Products

Data Loss Prevention Cloud Service for Email

Issue/Introduction

You are seeing "loop detected" for messages being sent through the DLP Cloud Service for Email.

This is happening in your O365 setup, even after following the default instructions for O365 Reflecting mode: Configuring Microsoft 365 to use Microsoft 365 for email delivery (Reflecting mode)

Environment

Release : 15.8 MP3+

Cause

In some cases, the creation of a secondary exception to prevent email loops may be required in the Transport Rule, in addition to the exception that is based on IP ranges.

Resolution

Add a secondary exception, as below, to force O365 to also check for the presence of an X-DetectorID header in messages being sent to the DLP service.

  1. In the "Except if" section of the Transport rule, click "+" (Add rule).
  2. In the first drop down, choose "The message headers" and in the second drop down choose "matches these text patterms".
  3. Click on the hyper-linked text that appears below, "Enter text". In the flyout window enter the value "X-DetectorID-processed". Note that this value is case sensitive, and should match the case as is already set in the same Transport rule where the header is added. Save that value.
  4. Click on the second hyperlinked text "Enter words". In the flyout window enter the value of the DetectorID for your Cloud Service for Email detector. This value also should match the header as set already in the same Transport rule.
  5. Save the configuration and wait ~10-15 minutes to confirm with testing.

Additional Information

This is only necessary in specific customer environments, where loops are reported for messages that are sent once but for Microsoftian reasons include all the headers of a prior message (as occurs with Email Delegation, for example).