Cannot alter user 'mdbadmin' during installation
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Cannot alter user 'mdbadmin' during installation

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Article ID: 269566

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When I try to install Service Desk Manager it throws error in the first task:

ERROR - The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "SQL Server did not return a response. The connection has been closed. ClientConnectionId:a1df6c19-adef-4899-9dfc-67d3420b4022".
05-10,18:58:3

The install.log file may contain the following:

2023/06/15 15.39.50.558 DEBUG [DeployThread: Configuración de las tablas comunes de CA Service Management] [InstallCDB] Msg 15151, Level 16, State 1, Server <SERVER_NAME>, Line 1

2023/06/15 15.39.50.558 DEBUG [DeployThread: Configuración de las tablas comunes de CA Service Management] [InstallCDB] Cannot alter the user 'mdbadmin', because it does not exist or you do not have permission.

 

Environment

All versions of Service Desk Manager

Admins are using IIS Crypto to create users

Cause

The customer site server administrator has configured the server's security protocols with a program called Crypto(see the link below) blocking permissions to the remote MDB database.

Resolution

 The database administrator created a new user ID with permission to access and modify the remote database. 

Additional Information

Please check any existing security configurations prior to install and production, if any exceptions need to be implemented. 

Service Desk cannot be redesigned to work around 3rd party security restrictions put into place.

IIS Crypto