Closing ticket in Aria chatbot Displays "Status of the ticket xx is updated to NONE"
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Closing ticket in Aria chatbot Displays "Status of the ticket xx is updated to NONE"

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Article ID: 269525

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When closing a ticket in Aria Chatbot we see the following message:

Status of the ticket XX is updated to NONE

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=lksigPp1nplFZZAtyv/z3g==

This message should reflect the correct status instead of NONE

Environment

Release : 17.3 RU22

Cause

This message is displayed as a result of API changes which do not allow us to dynamically retrieve the ticket status

Resolution

We can fix this message by modifying the following file:

xFlow\APPS\Services\collabmicroservice-17.0.479\conf\messages.en-US

Modify the following line:

BCF0028 = Status of the ticket @@ref_num@@ is updated to @@status@@

and change it to

BCF0028 = Status of the ticket @@ref_num@@ is updated to Closed

After that, please restart xFlow services and halt and start RASA.

This line is only related to the Close Ticket action so it is safe to make this change.

But as always, we recommend testing in a non production environment first.