The Permission denies while trying to edit favicon.ico file
search cancel

The Permission denies while trying to edit favicon.ico file

book

Article ID: 269481

calendar_today

Updated On:

Products

CA Identity Suite CA Identity Governance

Issue/Introduction

When we want to change the browser tab log sign, we need to edit the favicon.ico file, but when trying to change the file, it throws a permissions error

"Error #3" (/opt/CA/wildfly-idm/standalone/deployments/iam_im.ear/redirect.war/images/favicon.ico): Permission denied"

 

Environment

Vapp 14.4.2

Cause

In Vapp, the file belongs to user wildfly and it won't let us change it, it will generate the following permissions error.

"Error #3" (/opt/CA/wildfly-idm/standalone/deployments/iam_im.ear/redirect.war/images/favicon.ico): Permission denied"

 

Resolution

For Identity Manager running on Virtual Appliance:

Download the "1689762708017__HF_VA-14.4.2-20230719102113-DE571385.tgz.gpg" available in this article, and apply it on all applicable nodes. Also now the customer has to follow a new process for updating the favicon.

1. Apply the patch

2. Once the patch is applied successfully, go to the location /opt/CA/VirtualAppliance/custom/IdentityManager/images

3. The image is a new folder that is created under the custom location

4. Copy your own favicon.ico file under this folder with the same name.

5. Restart the Identity Manager

6. After successfully restarting, we should be able to see the updated favicon in the user console, if you can't see it, try deleting the browser cache or try in a new browser.

 

For Identity Governance running on Virtual Appliance:

Download the "1691065460476__HF_VA-14.4.2-20230802125707-DE573084.tgz.gpg" available in this article, and apply it on all applicable nodes. Also now the customer has to follow a new process for updating the favicon.

1. Apply the patch

2. After the patch is applied successfully, go to the location /opt/CA/VirtualAppliance/custom/IdentityGovernance/images

3. Images is a new folder I created under the custom location

4. Copy your own favicon.ico file under this folder with the same name.

5. Restart the Identity Governance

6. After successfully restarting, you should see an updated favicon in the user console, if you can't see it, try deleting the browser cache or try in a new browser.

 

For Identity Portal running on Virtual Appliance:

Apply the "HF_IP-14.4.2-20230821114143-DE573080_0001.tgz_1692984141171.gpg" file to customize the favicon file.

Follow the below steps to have a custom favicon for the Identity Portal admin console and user console in VAPP environment:

1.    Create a custom favicon.

2.    [Admin Console] Ensure that you rename the custom favicon name to admin-favicon.ico.

3.    [User Console] Ensure that you rename the custom favicon name to favicon.ico.

4.    Copy the custom favicon file to /opt/CA/IdentityPortal/resources.

 

Note:
1. If the custom favicon does not get updated, try clearing the cache or viewing it in a different browser.

2. Ensure that the favicon dimension is equal to or less than 32 x 32.

Attachments

HF_IP-14.4.2-20230821114143-DE573080_0001.tgz_1692984141171.gpg get_app
1691065460476__HF_VA-14.4.2-20230802125707-DE573084.tgz.gpg get_app
1689762708017__HF_VA-14.4.2-20230719102113-DE571385.tgz.gpg get_app