Access Gateway is starting, but not serving requests: error SM-SPS-02001
search cancel

Access Gateway is starting, but not serving requests: error SM-SPS-02001

book

Article ID: 269452

calendar_today

Updated On:

Products

SITEMINDER CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction

Access Gateway services are starting, but users see the following error in their browser when trying to access any of the virtual hosts:
SM-SPS-02001

Environment

Release : All

Cause

An invalid configuration existed in the server.conf file.  One of the virtual hosts had the hostname parameter specified as a full URL rather than only the host name (FQDN or just the hostname).

Resolution

Set the value of hostname to the FQDN of the virtual host, or just the hostname portion of the FQDN.  This parameter can be multi-valued via comma separated values.  This value(s) must match the incoming HTTP_HOST header of the incoming request to be mapped successfully to the proper virtual host.

Additional Information

server.conf location:
/secure-proxy/proxy-engine/conf