Cache Clear Required after each release or upgrade
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Cache Clear Required after each release or upgrade

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Article ID: 269375

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Many users reporting issues while accessing MUX screens post upgrade, where the user while access MUX is rendered a blank screen followed by an error "Page could not be loaded". The user is forced to clear the cache to overcome this and doesn't provides a pleasant user experience.

Steps to Reproduce: 

  • Use clarity in any of prior version let say 16.1.1
  • Upgrade to 16.1.2
  • Login back to MUX post upgrade 

Expected Results: User should be able to login to MUX 

Actual Results: MUX throws different errors until the browser cache is cleared 

Environment

Release : 16.1.2, 16.1.3

Cause

Index.html file under Clarity_home\tomcat-app-deploy\webapps\pm is cached and due to that client side static files are loaded causing mismatch of cache from server side 

Resolution

DE70714, will be addressed in release 16.2.0, but you will not see the benefit until the rollout of 16.2.1, henceforth you will have to potentially clear caches one more time once 16.2.0 is in place.

Workaround:

  • Clear the browser cache