SearchServer RU Install fails with Exit Code: 2004
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SearchServer RU Install fails with Exit Code: 2004

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Article ID: 269350

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager ServiceDesk

Issue/Introduction

Search Server RU20 installation is failing with this error message in the install.log file:

2023/04/20 18.24.30.869 DEBUG [DeployThread: Actualizaciones del servidor de búsqueda: 17.3.0.20] [PatchBase] ## Applying Search Server Patch using command : "C:\Users\******\AppData\Local\Temp\casm\Patching\17_3_20230420_180005\SearchServer-17.3.0.20_SEARCHSERVER_20230420_182120\SearchServer.exe" -i silent -f "C:\Users\******\AppData\Local\Temp\casm\Patching\17_3_20230420_180005\SearchServer-17.3.0.20_SEARCHSERVER_20230420_182120\searchserverinstallresponse.properties" -DIS_UPGRADE=true

2023/04/20 18.24.37.767 DEBUG [DeployThread: Actualizaciones del servidor de búsqueda: 17.3.0.20] [CommonProcessUtilities] Command terminated with exit code: 2004
2023/04/20 18.24.37.767 DEBUG [DeployThread: Actualizaciones del servidor de búsqueda: 17.3.0.20] [PatchBase] Search Server Installation Exit Code: 2004

 

 

Environment

Search Server

Release : 17.3, 17.4 and up

 

Cause

Installer exiting with a return code as 2004 means "The installation failed because not enough disk space was detected during the execution of the Install action.". 

This was puzzling because the installation drive had 17GB of free space which should be more than enough.

We searched the drive where Service Desk was installed for any Service Desk-related log files. 

These could be in several different folders depending on which components are installed (ex: xFlow, Catalog, SearchServer, etc).  We found that the log folders had never been cleared out over several years of usage and that the log files were taking up 75 GB or more of space. 

The RU patch installer was backing up the entire CASearchServer folder including the log files, so this is why the installer was running out of space.

Resolution

Freed up enough space for the Search Server upgrade to succeed

Some examples of things to delete:

Service Desk-related log files (C:\Program Files (x86)\CA\Service Desk Manager\log) over 1 year old 

Search Server logs from C:\Program Files\CA\SC\CASearchServer\elasticsearch-x.x.x\logs

In one case we found a zipped backup of the original search server indexes that was 30GB

Additional Information

During the Search Server upgrade the SearchServer elastic search folder and indexes are backed up which requires disk space

This can have a high disk space requirement depending on the environment