Empty page when trying to Edit Policy Rules from Web VPM/Visual Policy Manager (via Management Center or ProxySG)
search cancel

Empty page when trying to Edit Policy Rules from Web VPM/Visual Policy Manager (via Management Center or ProxySG)

book

Article ID: 269258

calendar_today

Updated On:

Products

ProxySG Software - SGOS Management Center - VA Management Center Management Center

Issue/Introduction

Empty page comes up when trying to Edit Policy Rules from Web VPM (via ProxySG or Management Center).

For example: Inside a Policy Layer, in a Policy Rule, click on the object you have under 'Source', and select Edit. It will open up a page with no content. See below:

Java based Legacy VPM may show the content but not the Web VPM.

Cause

This problem may not happen on all Proxy Devices, it could happen only on few select Proxies or just one Proxy. This problem is due to the older Web VPM version 2.1.4.

 

Resolution

1. If you are accessing the Web VPM via Management Center, you will have to load a new Visual Policy Manager package version 2.1.6.

a. Go to Support download portal and download VPM 2.1.6 (Edge SWG (ProxySG) Visual Policy Manager). 

b. Install the package on MC. Administration > Packages > Add Package 

c. After that, when you go to Policy and Launch VPM Editor, select the drop down next to 'Launch VPM Editor' > Launch Web-Based VPM > Launch from - Package > VPM Package > Edit and Select 'Edge SWG (ProxySG) Visual Policy Manager - version 2.1.6.

or

you can select Launch from 'Reference Device' but the 'SW version' on the 'Reference Device' has to be 7.3.14.1 or above (Note: 7.3.14.1 included Web VPM 2.1.6.

 2. If you are accessing Visual Policy Manager via Proxy management console (not via Management Center) then you will have to upgrade the SW version to 7.3.14.1 or above (that includes Web VPM 2.1.6).