Origin group is enabled in OC but shows disabled in settings
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Origin group is enabled in OC but shows disabled in settings

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Article ID: 269241

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I have Automatic Groups enabled - or so I thought - because I can see groups being automatically created based on 'Origin':

The origin-based groups appear to be working and updating properly but the Settings page shows that this is not even enabled:

Why is this happening?  How can I disable this group or allow the settings to reflect the proper status?

Environment

  • Release: 20.4

Cause

  • In older versions of UIM, the CM_GROUP_AUTOMATIC table contained 'origin' in the field whereas now 'any_origin' is expected.
  • This should have been updated by a previous upgrade but sometimes it does not get updated properly.
  • If this field was not updated you will experience this behavior.

 

Resolution

In UIM/OC 20.4 CU8 this is fixed so that it will properly show enabled in Settings when the field in CM_GROUP_AUTOMATIC contains 'origin'

As a workaround, run the following query against your UIM database:

   UPDATE CM_GROUP_AUTOMATIC SET FIELD = 'any_origin' WHERE FIELD = 'origin';

Log out of OC and back in and the Settings page should reflect the proper status, allowing you to change or disable it.