Export to CSV fails in Task's todo grid
search cancel

Export to CSV fails in Task's todo grid

book

Article ID: 269172

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Export to CSV is not working when downloading in the ToDo's popup after clicking the expand button.

Steps to Reproduce:

    1. Login as admin/admin
    2. Navigate to any project -> tasks 
    3. Click on any task and open the details page 
    4. Navigate to ToDo's tab and click on the expand button
    5. Ensure that the todo grid is opened in the expanded mode (modal window).
    6. Now click on the export to CSV button.
    7. Ensure that the 'Export is in progress...' notification is shown.

Expected Results:
The export to finish successfully and csv file generated properly.

Actual Results:
Observe that the 'Could Not Export CSV' notification is shown.

 

Environment

Release : 16.1.2

Cause

http://ppm_URL:ppm_PORT/ppm/rest/v1/private/checkRunningExportJob?filter=(resourceUrl=%2FobaTodos%3Ffilter%3D(obaAssociation%20%3D%20%40OBA_ASSOCIATION_ID%40)%26fields%3Dcompleted%2Cname%2Cowner%2CdueDate%26sort%3Dcompleted%20asc%26tsvParams%3D(workEffortUnit%3Dpct))

 

obaAssociation id is not added properly.

RESOURCE URL
/obaTodos?filter=(obaAssociation = @OBA_ASSOCIATION_ID@)&fields=o_prioridad,completed,dueDate,name,owner,createdDate,blocked,blockedReason&sort=o_prioridad asc&tsvParams=(workEffortUnit=hours)

Resolution

This is reported as DE69722.

A fix will be included in 16.1.3