AHD05949 error during attempts to upload attachments
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AHD05949 error during attempts to upload attachments

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Article ID: 269118

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Had fresh installation of Service Desk Manager

we have problem with uploading attachments to requests, getting "AHD05949:  Unable to acquire a repository session.  File not uploaded"

it happens with every file (png, jpg. xls, xlsx...)

Environment

Release : 17.3

Cause

suspecting that there is a mismatch on the server name specification, usually due to case sensitivity issues with the environment.

This is based off the following stdlog that was found on the rep_daemon process:

rep_daemon             11524 ERROR        ArchivePurge.c         670 Unable to locate server record, unable to process Restore requests

Resolution

Please do the following to address the issue.

- On your SDM Server, go into an admin command prompt and run the command "hostname".  Take note of the exact spelling and case of the server name.

- Go into SDM as an Admin user.  Under Administration tab, System -> Servers, locate the SDM Server entry and update the hostname to match the above command prompt output, which may most likely be all uppercase, under the hostname and attachment servlet path fields.  For the attachment servlet path, the value should be "http://<host>:8080/CAisd/UploadServlet"