Couldn't save the policy settings in SPE 9.0.1 application console
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Couldn't save the policy settings in SPE 9.0.1 application console

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Article ID: 269070

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

Couldn't save the policy settings in newer version i.e, SPE 9.0.1 after upgrade
When entering settings and clicking Apply changes button, the settings are blank again.
 

Environment

Release : 9.0.1

Errors similar to the following appear in the Cmaf.log of the SPE 9 Console:

2023-06-30 19:38:10,236 [http-nio-8008-exec-1] INFO  symantec.spe.helper.XMLReaderWriter:158 - reading Attribute: /filtering/Container/MaxCompressionRatio/@value
2023-06-30 19:38:10,236 [http-nio-8008-exec-1] INFO  symantec.spe.repo.ArchiveSettingsRepository:70 - loading object...
2023-06-30 19:38:10,236 [http-nio-8008-exec-1] ERROR spe.authentication.filters.JwtRequestFilter:100 - Exception occurred: org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NumberFormatException: For input string: ""

 

Errors similar to the following appear in file SPE_REST_API.log on the SPE 9 Server. Note the timestamps which match the log entries from the Cmaf.log, above.

2023-06-30 19:38:10,236 [http-nio-8008-exec-1] INFO  symantec.spe.helper.XMLReaderWriter:158 - reading Attribute: /filtering/Container/MaxCompressionRatio/@value
2023-06-30 19:38:10,236 [http-nio-8008-exec-1] INFO  symantec.spe.repo.ArchiveSettingsRepository:70 - loading object...
2023-06-30 19:38:10,236 [http-nio-8008-exec-1] ERROR spe.authentication.filters.JwtRequestFilter:100 - Exception occurred: org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NumberFormatException: For input string: "

 

 

Cause

File corruption of one or more .xml files prior to upgrade.

Resolution

  1. If you observe empty values for each field on multiple panes within the console, backup the .xml files to another folder, then uninstall and reinstall SPE 9 Server to generate new .xml files with the default settings.
  2. If this is the only pane of the console where this issue seems to occur, then workaround with the following procedure.

 

To insert MaxCompressionRatio into the file filtering.xml on the SPE 9.0 server

  1. At cmd prompt, type:
    cd C:\Program files\Symantec\Scan Engine
  2. Type:
    copy filtering.xml filtering.bak

    Expected output:
    1 file(s) copied
  3. To check whether MaxCompressionRatio is present, type: 
    find /c "MaxCompresstionRatio" filtering.xml
    Expected output is 0, indicating not present

  4. To confirm the xmlmodifier can see MaxCompressionRatio, type:
    xmlmodifier -q /filtering/Container/MaxCompressionRatio/@value filtering.xml

    error expected

  5. To insert the missing MaxCompressionRatio, type:
    xmlmodifier -s /filtering/Container/MaxCompressionRatio/@value 75 filtering.xml
  6. To confirm the xmlmodifier insert succeeded, type: 
    xmlmodifier -q /filtering/Container/MaxCompressionRatio/@value filtering.xml
    expected to display value of 75

  7. Either restart the "Symantec Protection Engine" service in services.msc or type:
    net stop symcscan

    net start symcscan
  8. Attempt to reproduce. Open the SPE 9 console, select the NON-prod server, and click Container Settings
  9. If the Console displays these settings, then one or more of the .xml files  of the SPE 9 component were corrupted. This may be the start of further settings challenges, needing fixes for one panel at a time.

 

 

 

Additional Information

How can I get debug logs for the SPE 9 Console and SPE 9 RESTAPI? 

See Enable Debug logging for Protection Engine 9.0 Console and REST API