Telemetry data is not showing on SDM
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Telemetry data is not showing on SDM

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Article ID: 268987

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

Telemetry manager process not starting properly and below errors  are appearing.  

sdmtelemetry.log: 

05/23 13:21:36.437 [main] ERROR SDMTelemetryManager 201 SQL exception occured:  
com.microsoft.sqlserver.jdbc.SQLServerException: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "The server selected protocol version TLS10 is not accepted by client preferences [TLS13, TLS12]". ClientConnectionId:b91c3844-fc06-42e9-8557-c8588abcb7ca
    at com.microsoft.sqlserver.jdbc.SQLServerConnection.terminate(SQLServerConnection.java:2892)
    at com.microsoft.sqlserver.jdbc.TDSChannel.enableSSL(IOBuffer.java:1881)
    at com.microsoft.sqlserver.jdbc.SQLServerConnection.connectHelper(SQLServerConnection.java:2452)
    at com.microsoft.sqlserver.jdbc.SQLServerConnection.login(SQLServerConnection.java:2103)
    at com.microsoft.sqlserver.jdbc.SQLServerConnection.connectInternal(SQLServerConnection.java:1950)

Environment

Service Desk Manager: 17.3.x

Cause

For some reason Telemetry Manager process is trying to establish SSL connection with the SQL server using TLS1, TLS1.1 connection.

Resolution

Steps:

1. Take backup of java.secruity file from the location   <JRE_XXX>/lib/security folder for OpenJDK 8 or conf/security for OpenJDK 11 and higher
2. Modify java.security file to remove TLSv1 and/or TLSv1.1) jdk.tls.disabledAlgorithms in java.security file and save the file.
3. Restart Telemetry manager process by executing the command pdm_bounce "telemetry" .