After upgrading TDM Portal 4.10.206.0 the connection to the gtrep repository database fails
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After upgrading TDM Portal 4.10.206.0 the connection to the gtrep repository database fails

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Article ID: 268934

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

After we upgraded our TDM Portal to release 4.10.206.0, we see that the service starts, but none of the micro-services are started. 

In the TDMSchemaManagementStartup.log we see the following error:

[ERROR] ---                           o.a.t.j.p.ConnectionPool:  Unable to create initial connections of pool.
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Environment

Release : TDM Portal 4.10.205.0 through 4.10.208.0

Cause

This problem is only seen for TDM Portal releases 4.10.205.0 through 4.10.208.0 upgrades. The issue is only seen where the gtrep repository database is running on SQL Server. New installations of TDM Portal, or reinstallation of TDM Portal, do not have this issue.

The problem is related to an updated SQL Server driver. Because of the upgrade process, the application.properties file is not touched, and therefore does not contain required parameters for the SQL Server connection URL used by the gtrep repository.

This will be addressed in a future release of TDM Portal. For now, some extra steps are needed when upgrading and connecting to a gtrep repository on SQL Server.

Resolution

After upgrading to TDM Portal 4.10.205.0 or 4.10.206.0, please do the following:

  1. Stop the CA Test Data Manager Portal service

  2. Updated the C:\Program Files\CA|CA Test Data Manager Portal\conf\application.properties file, and append  ;encrypt=true;trustServerCertificate=true to the spring.datasource.url property.
    For example: spring.datasource.url=jdbc:sqlserver://[hostname].[domain]\\[instance_name]:[port];database=gtrep;encrypt=true;trustServerCertificate=true

  3. Delete the expanded folders in the C:\Program Files\CA|CA Test Data Manager Portal\tomcat\webapps directory
    IMPORTANT: DO NOT DELETE the ROOT directory, or the *.war files.

  4. Delete the logs inside the %ProgramData%\CA\CA Test Data Manager Portal\logs directory

  5. Restarting the CA Test Data Manager Portal service.