Upgrade to 16.1.1 or 16.1.2 fails due to duplicates in odf_ui_view_settings
search cancel

Upgrade to 16.1.1 or 16.1.2 fails due to duplicates in odf_ui_view_settings

book

Article ID: 268648

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Upgrade fails due to duplicates in odf_ui_view_settings  in Board view 

Steps to Reproduce: 

 

  1. Start an upgrade from 16.1.0 to 16.1.1 or 16.1.2 
  2. Upgrade fails with below error in install.log 
    6/02/23 5:14 PM (ExecTask) Process - post-upgrade: POSTUPGRADE_BRYNTUM_BOARD_VIEW_OPTIONS.xml
    6/02/23 5:15 PM (ExecTask) Process - post-upgrade: POSTUPGRADE_BRYNTUM_BOARD_VIEW_CARD_FIELDS.xml
    6/02/23 5:15 PM (ExecTask) Process - post-upgrade: POSTUPGRADE_BRYNTUM_BOARD_UPD_VIEW_CARD_CONFIG.xml
    6/02/23 9:01 PM (ExecTask) java.sql.BatchUpdateException: error occurred during batching: ORA-01422: exact fetch returns more than requested number of rows
    6/02/23 9:01 PM (ExecTask) ORA-06512: at line 25
    6/02/23 9:01 PM (ExecTask) ORA-06512: at line 25

     

Expected Result: The upgrade should be successful 

Actual Result : Upgrade fails with the below error stack 

Environment

Clarity Version 16.1.1 & 16.1.2 

Cause

DE70260 The problem seems to be with duplicates in odf_ui_view_settings and with the board changes

Resolution

  • Roll back the upgrade and reach out to Broadcom Support for clean up script.