O365 accounts are not getting explored by IAM
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O365 accounts are not getting explored by IAM

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Article ID: 268365

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

We are using O365 endpoint as one of our connectors and have noticed that a few users are not being pulled up by the IM connector from O365. Those accounts have nothing different as such and are also on the same domain as other valid users.

Environment

Release : 14.3

Cause

We did check from Powershell that users are not returned using commands used by the IM:

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-management-and-governance-connectors/1-0/connectors/microsoft-connectors/microsoft-office-365/connect-to-office-365.html

get-msoluser -domainname <domain> -all | select userprincipalname | fl -- Affected users are not listed
get-msoluser -domainname <domain> -returndeletedusers -all | Sort-Object -Property UserPrincipalName | select userprincipalname | fl -- Affected users are not listed

Resolution

The customer was advised to speak to Microsoft Support regarding differences between users returned and not returned by the command.

IM cannot do anything on users that are not returned by Endpoint.

We got a response from O365 team, after adding the domain address as the user's proxy addresses the accounts are now explored and brought up in IAM.