IM. EAR goes down after AD connectivity
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IM. EAR goes down after AD connectivity

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Article ID: 268355

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Whenever there are any AD connectivity tasks the IM application is going down and stops responding.

Need to restart the server for making the server up and running.

Environment

Release: 14.x

Cause

In this case, the IDM is not getting sufficient LDAP connection. OOTB IDM provides only 50 LDAP connections. So in some cases, we need to tune the JNDI parameters as per the requirement. 

Resolution

Set the value for the below JNDI parameters


-Dcom.sun.jndi.ldap.connect.pool.timeout=10000

-Dcom.sun.jndi.ldap.connect.timeout=30000

-Dcom.sun.jndi.ldap.connect.pool.maxsize=500

-Dcom.sun.jndi.ldap.read.timeout=5000

-Dcom.sun.jndi.ldap.connect.pool.prefsize=100

Additional Information

Reference: DE567626