After exiting the Java client, the client connection on the server stays in close-wait status resulting in the inability to log back in to Java client
search cancel

After exiting the Java client, the client connection on the server stays in close-wait status resulting in the inability to log back in to Java client

book

Article ID: 268237

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

With a firewall enabled/required, when exiting out of the Java Client, the RMI server does not close the connection. When opening another Java client to log in, the below error is seen.

"AwE-5009 RMI connection failure, check if RmiServer is running."

Additionally, if grepping for the connection, the connection sits in a CLOSE-WAIT status. Below is an example result when grepping for the port number:

[app@appworx ~]$ sudo ss -ntp | grep 9001
CLOSE-WAIT 0      0       [::ffff:192.0.2.1.10]:9001                 [::ffff:192.0.2.24]:9006                users("java",pid=11414,fd=140))

A restart to the RMI process or manually kill the connection allows the User to be able to login again.

Environment

Release : 9.4.x

Cause

This is a bug in the code when SSL is set to "No" in the awenv.ini and "Off" in the Options.properties.

Resolution

Workarounds:

1. Restart RMI process or kill the connection
Or
2. Enable SSL by setting the below parameters:

awenv.ini
SSL=Yes

Options.properties
SSL=On

Note that enabling SSL parameters require SSL certificates (user_keystore and user_keystore_config)


Solution:

A fix (AM-3059) will be included in Applications Manager version 9.5.0. 

In the fixed version, SSL can be disabled without affecting client connections closing properly