Wildfly logging for Identity Manager: logs being overwritten, not saved at all, written to the wrong date log file.. logging only SEVERE messages
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Wildfly logging for Identity Manager: logs being overwritten, not saved at all, written to the wrong date log file.. logging only SEVERE messages

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Article ID: 268089

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Updated On: 06-16-2023

Products

CA Identity Suite

Issue/Introduction

What we are still observing today, and we are now running CP1 CH2, is that as previously reported IM can stop logging all but SEVERE level messages to server.log.

In our case it is still actively logging to the file that has yesterday's timestamp on it.

Below we see the contents of /opt/CA/wildfly-idm/standalone/log.

Note the small size of server.log and the active logging going to server.log.2023-03-09 and wildfly-console.log.  This means tail_im_log only shows SEVERE level messages.

 

 

Environment

Release : 14.4 CP1 CHF2

Cause

The issue is with logs being overwritten, not saved at all, or written to the wrong date log file.

Resolution

Standalone-full-ha.xml made sure to have the line:

<file-handler name="FILE" autoflush="true">
<formatter>
<named-formatter name="PATTERN"/>
</formatter>
<file relative-to="jboss.server.log.dir" path="server.log"/>
<append value="true"/>
</file-handler>

Additional Information

If this is vApp you will need to use Hotfix HF_IMS-14.4.1-20221124181821-DE547824_TMP.tgz.gpg to change standalone-full-ha.xml file on the machine.

Please request it from support.