SOI - unable to clear null class alerts: You do not have permission to clear this alert.
search cancel

SOI - unable to clear null class alerts: You do not have permission to clear this alert.

book

Article ID: 267991

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

I can see some old alerts in SOI queue wiev with "null class".

When I try to clear them I'm getting error : Major alert on null of class : You do not have permission to clear this alert.

Environment

Release : SOI 4.2

Cause

Corrupt/no class alarms 

Resolution

The alarms need to be deleted from the DB.

First, build a select statement that selects all your alarms you can proceed with using the same query with a Delete. 

Example: 

If the following query returns the list of alarms affected (just an example, you could filter out a WHERE with other attributes, but the idea is to select all the alarms that cannot be deleted)

 

select * from Alerts WHERE loggedtime < '2021-10-29 13:05:12.273' and ModelElementID is not Null

--once alarms appear in your select statment then execute: 

delete from Alerts WHERE loggedtime < '2021-10-29 13:05:12.273' and ModelElementID is not Null

Additional Information

Backup/Snapshot SOI/SOI DB first or Verify with Broadcom Support