New client authentication failed with invalid passphrase fills universe.log
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New client authentication failed with invalid passphrase fills universe.log

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Article ID: 267980

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

A Dollar Universe node that was unregistered and registered has the following series of errors present on the universe.log continously:

| 2023-05-30 17:46:18 |ERROR|X|IO |pid=P.T| kTrtAuthRequest           | Authentication failed: invalid passphrase (error -1)
| 2023-05-30 17:46:18 |ERROR|X|IO |pid=P.T| k_select_accept_aut       | kTrtAuthRequest in error [-1]
| 2023-05-30 17:46:18 |ERROR|X|IO |pid=P.T| u_io_thread_trt           | New client 49 (UVMS690/ on MYSERVER.MYDOMAIN.COM) authentication failed: Authentication error (Authentication request error)
| 2023-05-30 17:46:43 |ERROR|X|CDJ|pid=P.T| kTrtAuthRequest           | Authentication failed: invalid passphrase (error -1)
| 2023-05-30 17:46:43 |ERROR|X|CDJ|pid=P.T| k_select_accept_aut       | kTrtAuthRequest in error [-1]
| 2023-05-30 17:46:43 |ERROR|X|CDJ|pid=P.T| u_cdj_trt_req             | new client authentication failed: Authentication error

How can we get rid of these errors? The unims -unregister and unims -register of the node did not help.

Environment

Release : 6.x and 7.x

Component: Dollar Universe Application Server (Node)

Cause

The issue was caused by an old Univiewer Console Webstart hosted on MYSERVER.MYDOMAIN.COM that had been left opened in the workstation (Virtual Desktop) of a user.

Resolution

The error means that a UVC Console (on this case a Webstart but could also be a Standalone) hosted by the Tomcat server on MYSERVER.MYDOMAIN.COM had been started on a workstation (on this case a VDI server) since a long time and was still trying to display the JobChains and Job Runs of this node.

Unfortunately, since there were multiple VDI servers and the error message does not mention what user is involved, it was impossible to know from what UVC user it comes from or what is the VDI server where it was launched.

The easiest way to clear these errors would be restarting the Tomcat server/s hosting the UVC Webstart.

After that operation, the users will have to log again in UVMS and close their current UVC Webstarts.

Another option would be restarting all the VDI servers, but this would impact more the users.