GenericApplicationUser seen in Activity logs instead of actual user accounts
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GenericApplicationUser seen in Activity logs instead of actual user accounts

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Article ID: 267970

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Updated On:

Products

Web Isolation Cloud

Issue/Introduction

In your Web Isolation Activity logs you are seeing GenericApplicationUser instead user accounts.

Cause

Potential causes

  • Non-browser requests being received by Web Isolation.
  • Authentication being bypassed

Resolution

GenericApplicationUser will be seen in the user column in activity logs if non-browser requests get isolated (where we have a default application pass rule).

Another reason you may be seeing GenericApplicationUser is that authentication is being bypassed when "Authentication Caching" is enabled in Policy settings. 

To address the authentication issue:

From Web Isolation Management UI > Policies > All Policies 

  1. Click on the "pencil icon" to edit the active policy
  2. Scroll down the pop-up page to the "Authentication Caching" sections and uncheck the option "Apply authentication caching for non-browser application by source IP"