Scheduled DB backup configuration account selection not working
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Scheduled DB backup configuration account selection not working

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Article ID: 267956

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

We have two target accounts configured to be used for scheduled database backups. The target application names are "CAPAM_DatabaseBackup" as required and the accounts are configured with SSH key authentication. The account names are the same. When we try to configure the scheduled DB backup on the Configuration > Database > Backup Scheduler page, there is a drop-down available for the "Select Backup Target Account" setting, but it only lists one account. Renaming one of the target accounts allows us to see which one is available for selection, but we still have no control over which one should be used. This is a problem for us. We want to have a backup target account configured and ready to be set, and we may need to use different accounts/servers in different cluster sites.

Environment

Release : Any release prior to 4.1.3

Cause

The drop-down list was not implemented correctly. The call in the background only returned one account, and only displayed the account name. Typically there only is one account configured for this purpose, in which case it doesn't matter.

Resolution

This problem is fixed in 4.1.3+, see the following item on documentation page Resolved Issues in 4.1.3:

DE563208    Target Account selection broken for scp protocol option in DB backup scheduler.

 

The drop-down list has been replaced by an account picker that will include host and device name of the device the eligible target account belongs to: