Web server scan (Jive) scan gets stuck at 0 bytes without any progress
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Web server scan (Jive) scan gets stuck at 0 bytes without any progress

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Article ID: 267802

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Updated On: 06-12-2023

Products

Data Loss Prevention Network Discover

Issue/Introduction

When a Web server scan like a Jive scan is initiated, it does not progress and gets stuck at 0 bytes. 

Environment

DLP 15.8.x

Cause

Incorrect syntax used in the filters specified in the scan target. 

The SymantecWebServerScanner.cfg file had the below entry which comes from the filters configured on the Filters tab in the scan target:

UrlCantHaveRegex = *.pst,*.ost 

Also, the error.txt file had the below errors:

<tasks>
        <failed message="Failed to validate configuration 'WebConnectorSyncConfig':
[FetchTasks]UrlCantHaveRegex value '.pst,.ost' could not be converted to type 'basic_regex'">64_254934</failed>
    </tasks>

Resolution

The syntax used for any filters specified on the Filters tab in the Scan target should be a Perl-compatible regular expression else it will not work.

Example:

Incorrect filter syntax- *.pst,*.ost 

Correct filter syntax - .*pst.*|.*ost.*