Package Server Packages are in a Retrying Download Status
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Package Server Packages are in a Retrying Download Status

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Article ID: 267705

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

We're having an issue with brand new SMC Agents landing at a brand new site, where they can't download packages from the existing Package Server at our primary site.

We shut down the old package server, but there was an error deleting the server from Manage > Computers.

The Package Server's logs showed it was attempting to download from the old Package Sever. 

Environment

Release: 8.x

Cause

The old Package Server was still configured in Settings > Notification Server > Site Server Settings, so the package sources were still valid in the database. 

Resolution

We deleted the old Package Server from Site Server Settings, and updated the distribution points (the NS.Distribution Point Update scheduled task runs every 10 minutes by default, but you can also update it when reviewing a package).

After updating the configuration on the new Package Server and clicking Force Download for one of the packages showing a Retrying Download status, the package was successfully downloaded from a valid source. For any remaining packages in a Retrying Download status, either wait for the process to catch up or repeat the Force Download step to get all packages in that state to Ready status.