SPE 9 console login error - Fail to read the ldap registry key from the registry.
search cancel

SPE 9 console login error - Fail to read the ldap registry key from the registry.

book

Article ID: 267685

calendar_today

Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

When attempting to log into the Symantec Protection Engine (SPE) Console, the following error is thrown in a pop up box:

Fail to read the ldap registry key from the registry.

The following is the stack trace from "C:\Program Files\Symantec\Scan Engine Console\CMaF\logs\CmafUI.log"

2023-06-01 11:42:16,589 [1] INFO  Symantec.Cmaf.UI.FormSMSUI - main started..
2023-06-01 11:42:25,887 [1] ERROR Symantec.Cmaf.Security.AuthManager - Fail to read the ldap registry key from the registry.
2023-06-01 11:42:25,921 [1] ERROR Symantec.Cmaf.Security.AuthManager - 
 Time : Thursday, June 1, 2023 11:42:25 AM
 Outer Exception Type: Symantec.Cmaf.Common.Exceptions.SMSException
 Outer Exception Message: Fail to read the ldap registry key from the registry.
 Outer Exception Source: Symantec.Cmaf.Security
 ---Outer Exception Stack Trace--- 
   at Symantec.Cmaf.Security.AuthManager.GetLdapKeyValueFromRegKey()
   at Symantec.Cmaf.Security.AuthManager..ctor()
2023-06-01 11:42:28,217 [1] ERROR Symantec.Cmaf.UI.FormSMSUI - Exception Message:Fail to read the ldap registry key from the registry.
2023-06-01 11:42:28,218 [1] ERROR Symantec.Cmaf.UI.FormSMSUI - 
 Time : Thursday, June 1, 2023 11:42:28 AM
 Outer Exception Type: Symantec.Cmaf.Common.Exceptions.SMSException
 Outer Exception Message: Fail to read the ldap registry key from the registry.
 Outer Exception Source: Symantec.Cmaf.Security
 ---Outer Exception Stack Trace--- 
   at Symantec.Cmaf.Security.AuthManager..ctor()
   at Symantec.Cmaf.Security.AuthManager.<>c.<.cctor>b__25_0()
   at System.Lazy`1.CreateValue()
   at System.Lazy`1.LazyInitValue()
   at Symantec.Cmaf.UI.FormSMSUI.AuthenticateUser()
2023-06-01 11:42:28,218 [1] INFO  Symantec.Cmaf.UI.FormSMSUI - Symantec Cmaf Common UI Closing....

Environment

SPE Console 9.x

Cause

The following registry string was missing or its value was blank

HKLM\Software\Symantec\Cmaf\SPE\<VERSION>\Config\IsLdap

 

This registry string must exist and must be set to TRUE if using AD authentication when logging into the console.

Resolution

Create the string manually or save the following to a text file named "isLdap.reg" on the computer with the console program installed, then double click on it from the affected machine to import it.

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Cmaf\SPE\<VERSION>\Config]
@=""
"IsLdap"="TRUE"

 

If the SPE Console doesn't open after adding the registry string above, reinstall SPE Console following these steps:

  • Uninstall the existing console and re-install the console with "Run as Administrator" privilege.
  • Open the registry editor and verify the "IsLdap" key at "HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Cmaf\SPE\<VERSION>\Config".
  • Run the console with  "Run as Administrator" privilege.