Restoring archive config to VA edition from H/W appliance shows Log does not exist.
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Restoring archive config to VA edition from H/W appliance shows Log does not exist.

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Article ID: 267641

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Updated On:

Products

SSP-S210 PLATFORM SSP-S410 SSP-S410 PLATFORM ISG Proxy

Issue/Introduction

Some configuration errors show up on access-log section while configuration is being restored. This issue shows in bellow circumstances.

Proxy Edition running on legacy H/W appliances ( S200, S400, S500), and archived a configuration. 
Restore the archive configuration to VA(Virtual appliance), and there are following error messages in access-log section.

Blue Coat SG-VA Series#(config access-log)edit log cifs ;mode
% Log does not exist.
Blue Coat SG-VA Series#(config access-log)early-upload 100
  ok
Blue Coat SG-VA Series#(config access-log)exit
Blue Coat SG-VA Series#(config)edit log mapi ;mode

                                              ^
% Invalid input detected at '^' marker.
Blue Coat SG-VA Series#(config)early-upload 100

                                              ^
% Invalid input detected at '^' marker.
Blue Coat SG-VA Series#(config)exit
Blue Coat SG-VA Series#exit



Environment

It does not depend on SGOS version, but migration from Legacy H/W to VA. 

Cause

Edge SWG (ProxySG) VA version disabled MACH5 feature, and cifs/mapi accesslog names are disabled as a default. When the customer has modified cifs or mapi log name running on Legacy H/W, "edit log cifs" and "edit log mapi" are appeared in archive config. However, cifs/mapi names are not created in target VA version as a default. Hence, "% Log does not exist."  shows up and stop restoring.  


Resolution

Remove cifs/mapi sections in archived config file. Example:

!- BEGIN access_logging
access-log  ;mode
enable
edit log cifs ;mode
remote-size 10
exit
edit log mapi ;mode
remote-size 15
exit
exit
!- END access_logging

remove highlighted sections in red. 

After saving configuration, it can be restored without errors.