CABI - UIM Datasource Test Connection fails - Login failed for user
search cancel

CABI - UIM Datasource Test Connection fails - Login failed for user

book

Article ID: 267634

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

UIM Summary and UIM Summary Saas dashboards do not display data when launching dashboards from a direct CABIJs log on session

UIM Datasource Test Connection fails with error below

java.sql.SQLInvalidAuthorizationSpecException: [TibcoSoftware][SQLServer JDBC Driver][SQLServer]Login failed for user '[email protected]'. at tibcosoftware.jdbc.sqlserverbase.BaseExceptions.b(BaseExceptions.java:1075) at tibcosoftware.jdbc.sqlserverbase.BaseExceptions.a(BaseExceptions.java:977) at tibcosoftware.jdbc.sqlserverbase.BaseExceptions.a(BaseExceptions.java:1124) at 

Environment

CABI 8.00 configured with a domain service account (non SQL user)

Cause

Default JDBC Driver settings do not working properly in this scenario

Resolution

1. Login to cabi directly using superuser with superuser (default) as the password 
http://<XX.XX.XX.XX>:<port>/cabijs/login.html 
or
http://<cabitest.example.com>:<port>/cabijs/login.html 

2. In the Home page click on Data Sources

3. The UIM Datasource will display

4. Hover the mouse over the UIM Datasource, right click and select edit. 

Set JDBC Driver as shown below (standard connector with cabi probe 8.00.)

5. Change the  JDBC URL as followed (remove tibcosoftware)

From:

jdbc:tibcosoftware:sqlserver://uimdb.example.com:1433;databaseName=CA_UIM;integratedSecurity=true

To:

jdbc:sqlserver://uimdb.example.com:1433;databaseName=CA_UIM;integratedSecurity=true

6. Run the Test Connection and validate connectivity and click Save

7. Validate that UIM Summary and UIM Summary Saas dashboards display data