Session recording unavailable / Connectivity issues (can´t connect to servers)
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Session recording unavailable / Connectivity issues (can´t connect to servers)

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Article ID: 267488

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Error message when trying to access to devices saying the session recording is unavailable. Noticed that session recording filesystem was full. Increased the space and the external storage "request timeout" from 50 to 600 but didn´t help.

 

Environment

Release : 4.0

Cause

Support opened SSH session and noticed inside of log /opt/tomcat-sessionRec/logs/catalina.out is reporting outofmemoryerror

Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "Timer-0"
Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "http-nio-127.0.0.1-8080-ClientPoller"

Resolution

The root cause of problem sounds to be the disk full problem we had in filesystem /opt/rpath and for some reason tomcat process stayed weird internally reporting OutOfMemoryError. The restart  of PAM Node resolved the problem.