What information such as logs or files does Broadcom DX UIM support require when support cases are opened?
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What information such as logs or files does Broadcom DX UIM support require when support cases are opened?

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Article ID: 267444

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Updated On:

Products

CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

  • This article provides some clarification as to the information that needs to be collected and shared with Broadcom support when customers encounter a problem or issue with DX UIM server, Operator Console, or any UIM core probe.
  • This KB article addresses these questions listed below and more:
     
    • How do I use Raw Configure mode to set the probe loglevel and logsize?
    • What configuration files, e.g., <probe_name>.cfg and/or log files are required and where are they located on the file system?
    • Do I need to document the precise time or time ‘frame’ of the alarm/error/event/incident?
    • How do I debug the Operator Console (wasp) portal?

Environment

  • DX UIM (Nimsoft) any version
  • DX UIM Server core probes
  • Operator Console wasp

Cause

  • Guidance for troubleshooting and providing support with necessary information for faster troubleshooting and issue resolution.

Resolution


Default locations for probe logs and cfg files:


Windows
<INSTALL_DIR>\Nimsoft\probes\<probe_category>\nas

For example:
C:\Program Files (x86)\Nimsoft\probes\service\nas

Linux/Unix
<INSTALL_DIR>/Nimsoft/probes/<probe_category>/<probe_name>

For example:
/opt/nimsoft/probes/service/nas


DX UIM Server

Probe: hub

  • loglevel: 5 or 6
  • logsize: 200000
  • Files required:
    • hub.cfg
    • hub.log
    • _hub.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\hub
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/hub

Probe: data_engine

  • loglevel: 5
  • logsize: 200000
  • Files required:
    • data_engine.cfg
    • data_engine.log
    • _data_engine.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\slm\data_engine
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/slm/data_engine

Probe: robot (controller)

  • loglevel: 5 or 6
  • logsize: 100000
  • Files required:
    • robot.cfg
    • controller.log
    • _controller.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\robot
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/robot

Probe: discovery_server

  • loglevel: 5
  • logsize: 200000
  • Files required:
    • discovery_server.cfg
    • discovery_server.log
    • _discovery_server.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\service\discovery_server
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/discovery_server

Probe: mon_config_service

  • loglevel: 5
  • logsize: 200000
  • Files required:
    • mon_config_service.cfg
    • mon_config_service.log
    • _ mon_config_service.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\service\mon_config_service
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/mon_config_service

Probe: nas

  • debug: (not loglevel): 3
  • logsize: 100000
  • Files required:
    • nas.cfg
    • nas.log
    • _nas.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\service\nas
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/nas

Probe: alarm_enrichment (configured via nas.cfg)

  • enrichment_loglevel: 5
  • enrichment_logsize: 100000
  • Files required:
    • alarm_enrichment.cfg (only for setting java heap memory)
    • alarm_enrichment.log
    • _alarm_enrichment.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\service\nas\alarm_enrichment
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/nas/alarm_enrichment

Probe: wasp

  • loglevel: 5
  • logsize: 100000
  • Files required:
    • wasp.cfg
    • wasp.log
    • _wasp.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\service\wasp
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/wasp

Probe: automated_deployment_engine (ADE)

  • loglevel: 5
  • logsize: 50000
  • Files required:
    • automated_deployment_engine.cfg
    • automated_deployment_engine.log
    • _automated_deployment_engine.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\service\automated_deployment_engine
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/ automated_deployment_engine

Probe: baseline_engine

  • loglevel: 5
  • logsize: 100000
  • Files required:
    • baseline_engine.cfg
    • baseline_engine.log
    • _baseline_engine.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\service\ baseline_engine
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/baseline_engine

Probe: qos_processor

  • loglevel: 5
  • logsize: 50000
  • Files required:
    • qos_processor.cfg
    • qos_processor.log
    • _qos_processor.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\slm\ qos_processor
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/slm/qos_processor

Probe: distsrv

  • loglevel: 5
  • logsize: 50000
  • Files required:
    • distsrv.cfg
    • distsrv.log
    • _distsrv.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\probes\service\distsrv
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/probes/service/distsrv

Operator Console (OC)

Probe: robot (controller)

  • loglevel: 5
  • logsize: 100000
  • Files required:
    • robot.cfg
    • controller.log
    • _controller.log (archived log when it reaches the logsize limit)
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows): C:\Program Files (x86)\Nimsoft\robot
    • Logs/.cfg location (Linux/UNIX): /opt/nimsoft/robot

Probe: wasp

  • loglevel: 5
  • logsize: 100000
  • Files required:
    • wasp.cfg
    • wasp.log
    • _wasp.log (archived log when it reaches the logsize limit)
    • .har file exported from Browser developer tools (F12) at the time of the action taken, e.g., login, select group, etc.
    • Precise time or time ‘frame’ of the error/event/incident
    • Logs/.cfg location (Windows):
      • C:\Program Files (x86)\Nimsoft\probes\service\wasp
      • C:\Program Files (x86)\Nimsoft\probes\service\wasp\operatorconsole.log
    • Logs/.cfg location (Linux/UNIX):
      • /opt/nimsoft/probes/service/wasp
      • /opt/nimsoft/probes/service/wasp/operatorconsole.log

Installation/Upgrade Logs

DX UIM Server on Windows
C:\tmp\ca_uim\uimserver_ia_install.log

Operator Console (OC) on Windows
C:\tmp\ia\oc.log

DX UIM Server on Linux/Unix
/tmp/ca_uim/uimserver_ia_install.log
 
Operator Console (OC) on Linux/Unix
/tmp/ia/oc.log

Additional Information

  • One or more screenshots of the crash/error/incident are always helpful.
  • Provide a Word doc if time allows illustrating the sequence of configuration or general steps taken that led up to the event/error/issue.
  • Provide a short recording if feasible to help with understanding the issue more clearly (optional)

Other helpful references


Basic troubleshooting steps for all probes

UIM log file locations for DX UIM Web apps like apache, tomcat, websphere, etc.

How to generate a .har file for DX UIM support cases