ConfigException occured 'ConfigDll could not find the config toolbox'
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ConfigException occured 'ConfigDll could not find the config toolbox'

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Article ID: 267422

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Updated On:

Products

Deployment Solution

Issue/Introduction

When we run a task to join a computer to the domain, the task is erroring with the following message:

ErrorMessage: ConfigException occured 'ConfigDll could not find the config toolbox', return code 0, system error 'The system cannot find the file specified (0x00000002)', location 'ConfigDll.cpp:154'

The account they're using to join the computer to the domain has been confirmed to have appropriate permissions, and it does work if they join the domain manually with those same credentials.

If they run the task but doesn’t specify an OU to move it to, it works fine and is joined and placed under the root Computers OU.
If they specify an OU, they get this error. They’ve checked that the OU they’ve specified in the task exists, and they’ve re-confirmed that the account in question has rights to move computers into the task’s specified OU when done directly via AD Users and Computers.

Environment

Deployment Solution 8.6, 8.7

Cause

This error appears when DS (Deployment Solution) cannot find config.dll, it may be that some part of running job is upgrading Agent files and corner case appears when file is missing at some point.

Resolution

This error appears in case of a failed attempt to find the config file (config.dll) in either the directory where the parent executable is located, or in a directory specified in registry value "AgentInstallPath" under registry key "HKLM\SOFTWARE\Altiris\Deployment" 

Make sure the mentioned file exists. If not, you can copy it from a working environment.