DC081005 TERMINAL IS DEAD
search cancel

DC081005 TERMINAL IS DEAD

book

Article ID: 267366

calendar_today

Updated On:

Products

IDMS IDMS - Database IDMS - ADS

Issue/Introduction

We are getting many DC081005 error messages in the IDMS log:

DC081005 V90 T4504790 TASK:ADS2 PROG:ADSOMAIN; TERMINAL IS DEAD - MAP mmmmmmm    
 LTERM:  tttttttt
DC027007 V90 T4504790 TASK:ADS2 PROG:ADSOMAIN ABENDED WITH CODE D002       
DC259001 V90 User uuuuuuuu signed off lterm tttttttt at 14:28:55.87 23.152 

Environment

Release : 19.0

Cause

The DC081005 occurs when a terminal is disconnected from VTAM.
VTAM is notified of the disconnection and calls our VTAM LOSTTERM exit. You can verify the exit was called by checking the PTE in the dump. It will have the literal LOSTTERM at offset x'118'.
The exit logs off the user and resets the LTERM to make it available again. That's why you see the DC259001 user  signed off  message above.

Resolution

We can't tell from the message why the terminal was disconnected. 

It could be due to VTAM problems causing the session to be disconnected or users are deliberately disconnecting their terminal sessions for some reason.

Check for any VTAM messages in the syslog at the time these terminals were disconnected.