Unable to establish connection to remote machine
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Unable to establish connection to remote machine

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Article ID: 267296

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Deployment of agents with Deployment Wizard is failing on some computers with error :

Delivery failed   -  Unable to establish connection to remote machine

 

In TRC_CF_DMDEPLOY_*.log following error appears :

 

150323-10:55:49.3515421L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005059|DETAIL | Attempting to open share \\<CompName>\admin$
150323-10:55:49.3515746L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005082|DETAIL | Found user/pass info for <CompName>
150323-10:55:49.3515962L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005125|DETAIL |  szFullTargetUsername = <DMName>\<UserName>
150323-10:55:49.3516184L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005127|DETAIL | Calling WNetAddConnection2W
150323-10:55:49.3516413L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005130|WARNING| Max connection attempts: 2
150323-10:56:10.3841552L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005143|WARNING| Call no. 1 to WNetAddConnection2W failed, return code was: 53
150323-10:56:12.4010746L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005143|WARNING| Call no. 2 to WNetAddConnection2W failed, return code was: 53
150323-10:56:16.4182738L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005143|WARNING| Call no. 3 to WNetAddConnection2W failed, return code was: 53
150323-10:57:04.4401398L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|007973|DETAIL | The RPC server is unavailable.
150323-10:57:04.4402055L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005596|DETAIL |  The network path was not found.
150323-10:57:04.4404255L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|005707|DETAIL | Calling WNetCancelConnection2
150323-10:57:04.4409893L|000344|00001c5c|DMDeploy  |DmDeploy|cdmdeployer.cpp|004698|DETAIL | Failed to push primer to a remote Windows share. rc=<53>

Environment

Client Automation - All Versions

Cause

This problem could have multiple causes.
 
- remote machine is not on the network
- Port TCP 135 and/or 445 are blocked
- File and Printer Sharing for Microsoft Networks is disabled or is not installed

Resolution

1- From Domain Manager, try to ping the machine and map the share admin$ using ipaddress of target machine :
 
ping machine_name
net use x: \\ip_address\admin$ /user:DMName\UserName
 
2- Check if port TCP 445 and 135 are blocked or not.
This checking could be done with powershell command like :
 
Test-NetConnection -ComputerName <computer_addr> -Port 135 -InformationLevel "Detailed"
Test-NetConnection -ComputerName <computer_addr> -Port 445 -InformationLevel "Detailed"
 
TcpTestSucceeded should be True :
 
 
 
 
3- Try to disable Windows firewall on target machine and do again the test of step 1
 
4- On target machine execute following powershell command :

Get-NetAdapterBinding -ComponentID ms_server

Is "File and Printer Sharing for Microsoft Networks" enabled for the used network adapter ?

https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/system-error-51-53-access-shared-resources