Enable Ghost Solution Suite PXE Server configuration and PXE\MFTP logging
search cancel

Enable Ghost Solution Suite PXE Server configuration and PXE\MFTP logging

book

Article ID: 267264

calendar_today

Updated On:

Products

Ghost Solution Suite

Issue/Introduction

PXE Server configuration enable data logs to help  troubleshoot incidents on the PXE Servers. Enabling log files will help isolate issues with the network traffic, communication protocol, the PXE Server, and more. Each log has its own log file written to a directory path where you want to store the log files. Each log file lets you select a log level, such as errors, warnings, information, debug, or all. This is a valuable tool that should be used only for troubleshooting as it could impact the network in a production environment due to the amount of data that is written to the logs.

Environment

3.x

Cause

To know how to enable PXE \ MFTP and PXE Server Configuration logging and to know the logging levels

Resolution

Data log properties:

Use Shared properties Select this option when you set the properties for a
Shared Configuration. Once you set the properties,
you cannot change this selection on the other
pages.
Customize PXE Server: Shared Configuration This option is available when you select a specific
server from the File menu. You can also customize
the properties for the PXE Server you selected.
Log File Location  This is the folder where all log files are stored. If no
directory path is entered, log files are stored in the
default Ghost Solution Suite Share folder of
C:\Program Files\Altiris\express\Ghost Solution
Suite Server\PXE.
Log Files 

The following log files are specific to PXE Servers
and, if enabled, log the information to the filename
you specify and store it in the PXE folder on each
PXE Server across the network.

  • PXE Server Log
  • PXE MTFTP Log
  • Packet Parser Log
  • DS Traffic Log
  • Config Service Log
  • PXE Manager Log
  • Config Utility Log

The PXE Manager Log writes data to the filename
you specify and stores it in the PXE folder on the
Ghost Solution Server.

Level Select the type of data you want to write in the log
files. Each level in the list includes more details to
the log files of the previous level
Filename  Enter a name for the log file you enabled if you do
not want to use the default name.

 

Log Level settings are defined as: 

Logging Level 1:  A cursory logging. Log only important functions and important errors.

Logging Level 2: Logs Database errors.

Logging Level 3: Logs Functional flow

Logging Level 4: Logs important requests and response

Logging Level 5: Logs all requests and responses in client and server communication

Logging Level 6: Not used at this point in time. (meaning that we do not use messages with this value in debug)

Logging Level 7: Logs client Server related important parameters like client ip, cookies etc.

Logging Level 8: Not used at this point in time. (meaning that we do not use messages with this value in debug)

Logging Level 9: Deepest log level. In this log level, the application will print all messages written for printing. It gathers almost all data.

 

Note:  Whenever log level is X, it will cover all logs from 1 to X.

Where X value is from 1 to 9

For example: If the current logging level is set at 4; Then all logs set from level 1 to level  4 will get printed in a log file