Failed power supply on servers and ME4/VA storage arrays
search cancel

Failed power supply on servers and ME4/VA storage arrays

book

Article ID: 267143

calendar_today

Updated On:

Products

Security Analytics

Issue/Introduction

A pink banner reports a hardware problem.  Looking in /var/log/messages, you might see a power supply (PSU) failure.  The most common fix for power supply problems is to re-seat the power cords.

Cause

This can be caused by a power supply failure, the power switch is off, or the power cord is not fully seated.

Resolution

The cause of the problem can be found by running as root from the command line, grep HARDWARE /var/log/messages.  The first indication of a problem is the message:

Powervault System Health: A subcomponent of this component is unhealthy.;

Look a few lines below for entries with the keyword PSU.  For example,

2022-05-31T15:00:18+00:00 hostnamehere POWERVAULT[318089]: snlog: sn="##:##:##:##:##:##" id="DS" m="23" c="6" event="DISK_STATUS" category="HARDWARE" ip="192.168.1.1" model="R640xl" msg="An Enclosure Management Processor (EMP) reported an alert condition on a power supply. Type: fault. (enclosure: 1, WWN: XXXXXXXXXXXXXX) power supply RIGHT, power supply status: Failure, DC failure, AC failure; "

This may be caused by loose power cords or by the power switch being off.  Push both ends of all cables found into the sockets.  Look for green lights on the power supplies.  Both supplies should have the same green status lights.  This is the most common fix for power supply problems.

Clear the pink banner in the Security Analytics Web UI by selecting the "X" to the far right side. If the pink banner appears again, generate a CSR, create a support case, and attach the CSR to the case.  Support will review the /var/log/messages file to assist in finding the cause of the problem.

If the power supply/PSU does need to be replaced, contact support with the event logs and shipping information.  A new PSU will be dispatched after a review.

The PSU can be replaced while the system is running.  Look in the back of the storage for an amber light on the right and left PSUs.  Press the tab and pull the PSU out.  Insert the new PSU in the same orientation as the old unit was removed.

Dell has provided good, short videos on PSU removal, if needed.

For the 12 drive enclosures, ie ME4012/VA012, see ME4012/VA012 PSU Replacement

For the 84 drive enclosures, ie ME4084/VA084, see ME4084/VA084 PSU Replacement

 

Additional Information

The log messages are specific to the storage array but the concept applies to the servers, also.