User photos do not appear in the ICA console
search cancel

User photos do not appear in the ICA console

book

Article ID: 267020

calendar_today

Updated On:

Products

Information Centric Analytics

Issue/Introduction

Users' photos are not displayed on User Details pages in the Information Centric Analytics (ICA) console after integrating ICA with Active Directory (AD), running the Bay Dynamics AD Connector Job, and running the nightly RiskFabric Processing job.

Environment

Release : 6.x

Component : Active Directory Connector Utility

Cause

By default, the AD Connector Utility does not import users' thumbnail photos. Per the utility's readme.txt file, this is an optional setting configured in the database:

"Note that thumbNailPhoto for Users is disabled by default. To enable it, set IsEnabled=1 in MetadataAttributes for the thumbNailPhoto entry."

Resolution

To enable thumbnail photos for users, follow this procedure:

  1. Open SQL Server Management Studio (SSMS)
  2. Connect to the Database Engine hosting the ActiveDirectoryDW database
  3. From the File menu, select New > Query with Current Connection, or press Ctrl+N
    A new query editor window will appear
  4. Copy the following statement and paste it in the new query editor window:
    UPDATE ActiveDirectoryDW.dbo.MetadataAttributes
    SET    IsEnabled = 1
    WHERE  ApiAttributeName = 'thumbNailPhoto';
  5. Execute the statement by pressing the F5 key, clicking the Execute button in the SQL Editor toolbar, or selecting Execute from the Query menu
  6. The following query can be used to confirm the setting is enabled:
    SELECT IsEnabled FROM ActiveDirectoryDW.dbo.MetadataAttributes WHERE ApiAttributeName = 'thumbNailPhoto';

After enabling this setting, the Bay Dynamics AD Connector Job must be run, followed by the nightly RiskFabric Processing job, in order to import thumbnail photos from AD and update users' details in ICA. These jobs will run according to their assigned schedules or you can start them manually via SSMS.

To start each job using SSMS, follow this procedure:

  1. Open SSMS
  2. Connect to the Database Engine hosting the RiskFabric database
  3. In Object Explorer, navigate to SQL Server Agent > Jobs
  4. Right-click the job Bay Dynamics AD Connector Job and select Start Job at Step...
    The Start Jobs - <hostname[\instance]> window will appear
  5. After the job has completed, right-click the job RiskFabric Processing and select Start Job at Step...
    The Start Job on '<hostname[\instance]>' window will appear
  6. Ensure Step ID 1 is highlighted and click the Start button
    The Start Jobs - <hostname[\instance]> window will appear