Late execution of SD Job with Boot Level Logoff User
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Late execution of SD Job with Boot Level Logoff User

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Article ID: 266539

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery

Issue/Introduction

Sometimes when a SD Package with 
Boot Level Before execution = "Logoff user"
is sent to a machine, the logoff is done but the SD Job execution does not start immediately. It starts after about 10 minutes.
 

Environment

Client Automation 14.5 CU5

Cause

This problem occurs when SD Package has boot option :
Boot Level Before execution = "Logoff user"
 
and when Agents are using the new Toast Notification method.
DSM/Common Components/CAF/General/CAF Dialog: Enable Toast Notifications = True
 
Sometimes, due to a thread synchronization issue, the logoff is done with a delay and the new sdagent process could not start.
 
In TRC_CF_CAF_SERVICE_*.log we could see this :
220323-13:36:20.3828458L|004364|000011a0|CAF_SERVIC|caf |caf |000000|INFO | CFPlugins::startPlugin: Cannot start DSM service: a logoff is in progress. sdagent 

Resolution

Open a case at CA Broadcom Technical Support and request the fix T5IZ473 (for Agent 14.5 CU5)

This fix replaces the file cfCafDialog.exe and should be applied on the Agents.